忍者ブログ
[457] [460] [459] [462] [461] [464] [465] [467] [466] [468] [470]
×

[PR]上記の広告は3ヶ月以上新規記事投稿のないブログに表示されています。新しい記事を書く事で広告が消えます。

 ゲームとか作り始めて行くと、大きな問題にぶち当たりました。
それは、JavaScriptのバージョンで、このバージョンにより
出来る機能が違ってる。

すなわち、Ver1.1以前であれば、レイヤ機能がないので
画像を細かく動かして操作するようなゲームは出来ない。
これが出来るのがVer1.2以降なんだけど。

このバージョンは、ブラウザのバージョンに依存してる。
すなわち、NetscapeもIEも、最新のVer4以上でないとレイヤ機能は
使えない。

ということで、今までは、ブラウザも古いバージョンのものを
使ってる人もかなりいるだろうな、ということで、
JavaScript Ver1,1の機能で可能な範囲しか考えていなかった。

ところが、当サイトのアクセス解析を行った結果、
IEが約70%、NNは約30%、でブラウザのバージョンも
最新のバージョンが、約70%と高かったので、

うーーん、これは、このままJavaScript1.1にこだわって、
新しい機能を捨てるのは、もったいない環境だということが
分かった。

確かに、まだ古いバージョンを使っている人もいるが
これらの人は、PC買い換えたり、ブラウザの最新版も
雑誌にCDで添付されてるし、最新の環境にバージョンUP
することは、そんなに大変なことではない。

また、JavaScript1.1で使えるゲームは既にあるし、
今後は、JavaScript1.1でゲームを作ることは、
ネタ的にも、あまりなさそうだし。

ここは、こだわりを捨てて、新しいバージョンへジャンプ
した方がよさそうである。

ということで、今後はJavaScript1.2で前提で作成していく
ことに決めた次第です。

拍手[0回]

PR

コメント


コメントフォーム
お名前
タイトル
文字色
メールアドレス
URL
コメント
パスワード
  Vodafone絵文字 i-mode絵文字 Ezweb絵文字


トラックバック
この記事にトラックバックする:
忍者ブログ [PR]
カレンダー
07 2017/08 09
S M T W T F S
1 2 3 4 5
6 7 8 9 10 11 12
13 14 15 16 17 18 19
20 21 22 23 24 25 26
27 28 29 30 31
フリーエリア
[-]最新トラックバック
プロフィール
HN:
7maru
性別:
非公開
自己紹介:

バーコード
ブログ内検索
[+]アーカイブ
アクセス解析